A Million Simulations – Some Results

 

I spent the rest of August running simulations to see if I could find the root cause of the difference between simulations and actual, without much luck.

Besides looking for the source of the problem, I am also trying to make changes that keep the shape of the cavity the same.  Changing the shape would mean ordering a new one, but it could very well produce the same results.  I need to be able to make sure that what I simulate makes a difference in the real world.

Here are the things I checked:

  • The location of the probes in the actual cavity are in the same position as simulated (99mm from the lip of the large end)
  • Whether a grounded tuning plate makes much difference –  it doesn’t – a couple dB insertion loss (it will be grounded when under high power)
  • Whether a large gap around the edge of the tuning plate makes much of a difference
    • 4mm

      The tuning plate is also ungrounded results in 1.2dB insertion loss, yuck.
    • 8mm (huge gap!)
    • Analysis – The plate needs to be grounded and the gap should not be more then 4mm.  With a gap at 4mm and no proper grounding of the tuning plate,  we could see up to 1.2dB of insertion loss.  The resonant frequency and the Q did not change.
  • I also moved the location of the probes forward and backward from the current location at 292.5mm from the tuning plate
    The probe here is in the zero point of the field and doesn't create a TE0,1 mode at all.
    Can start to see the resonance deform.
    This is the currently implemented distance, 292.5mm
    This has the lowest insertion loss
    The TE01 mode was really weak at this position even though the insertion loss was great

     

    • Analysis – As expected, the best match is when the probe is centered in the peak of the field, around 280mm, and the current location is slightly forward of that at 292.5mm.  The resonance at 280mm had the same Q (76K), the same frequency (2.4425Ghz) but had a better insertion loss (0.5dB).   It is possible to plug the current probe hole with round copper stock and move the power probe backwards and opposite the measurement probe.  However, I have to check if I can move the probe a centimeter backward and still stay on the probe mount ring (pointed to by the arrow)

      Note to self – Create a wider mounting ring for the next cavity.
  • I have also started to lengthen the probe and it does have an affect, for example, it moved the resonant frequency downward by 100Mhz.  Unfortunately, it seems to have messed up the TE0,1 resonance as shown below and dropped the Q to 60K.

    Probe is extended 15mm into the cavity with a 25mm diameter loop on the end. Q is lower, insertion loss is excellent. Frequency is 2.4411Ghz.

    The probe is 30mm deep with a 15mm diameter probe, the TE0,1 is impure but note it moved to 2.438Ghz
    • Background– One of the neat features of CST’s microwave studio is the ability to insert variable names instead of numbers, for example, the diameter of the probe can be “diameter_of_probe” which you (or an optimization routine) can then change.  In practice however, changing a variable by a large amount usually breaks the model, for example, using a large diameter probe loop means it is too close to the probe mount.  Thus when changing a variable, a few other variables have to be adjusted too.  Besides running simulations, I also spent time building a more robust model that can handle large changes without breaking.I am now on version 2.02 of the model and can change the depth of the probes and the probe loop diameter without breaking it.I also fixed another problem – With earlier model versions, the lofts I used to connect the probe loop to the probe had numerous “degenerate tetrahedrals” which are really thin tetrahedrals.  Degenerate cells mean convergence of the adaptive meshing takes a long time, up to 8 or more samples.  Each sample also uses a large number of mesh cells, for example, I have had counts as high as 750K.  Without degenerate mesh cells, the model uses ~450K cells, and takes 4 samples to converge mesh adaptation.  (The number of samples to simulate depend on the frequency range, for example, a range of 25Mhz takes nine samples, a 100Mhz range can take 16 samples.  Even then, if the TE0,1 mode moved, it requires another couple frequencies to be simulated in order to see which resonance is the TE0,1 mode and what the Q is at that frequency)
    • Method – One of the problems to fix is that the frequency of the actual cavity for the TE0,1mode is 18Mhz higher then simulated (2.467Ghz vs 2.449Ghz).  If a longer probe moves the resonant frequency lower, then it should be possible to simulate a probe length that is 18Mhz lower and then the actual cavity should be at the right frequency.  If I can also get a rock bottom insertion loss (0.3dB or 0.4dB) and the Q isn’t too bad, then it might work.  Probes are easy to fabricate, especially long ones and it will be a good test to see if the simulation can result in real-world outcomes.Making the probe longer moves the TE0,1 mode lower, but messed up the field configuration.  At first, I tried a larger loop but that lead to a worse field configuration, but going in the opposite direction with a smaller loop fixed it. The simulations suggest that the total length of the loop is important to create a clean TE0,1mode.  It doesn’t matter if the loop is near the probe, only that it is the same total length from probe mount to termination on the cavity wall.Which is my next task, to optimize the probe length and diameter.

Simulating is a big time sink, because the simulations never run under 400K tetrahedrals and take at least two hours, which means I can do about three to four a day.

  • In preparation for a future cavity, I tested to see if an aluminum cavity made much difference compared to copper.  I was a bit shocked to find that a completely aluminum cavity had an insertion loss that was almost the same as copper (0.8dB vs 0.72dB), the frequency of the TE0,1 mode didn’t change and the Q was almost as high (60K vs 76K)!!  After talking it over with Kevin, it would seem this is because the TE0,1 mode is zero along all the walls (but not at the end plates)  Aluminum has something like %60 less conductivity than copper!
Aluminum cavity

Here are the Q calculations between the two, first copper:

Frequency/Hz  2.44270000e+009
Energy/J      2.68158093e-007

Layer     Solid       Conductivity   Mue           Loss/W(peak)  Q
—————————————————————————-
Copper (hard-drawn)   5.9600e+007    1.0000e+000   1.0743e-001   7.6618e+004
Resonator:Cavity                         9.3921e-002   8.7641e+004
Measurement Probe:Probe                  3.5290e-003   2.3325e+006
Power Probe:Probe                        2.4124e-003   3.4121e+006
Resonator:Tuning Plate                   7.5663e-003   1.0879e+006
Resonator:Tuning Plug                    4.3164e-006   1.9070e+009
PEC                   5.8000e+007    1.0000e+000   3.2168e-004   2.5588e+007
Power Probe:Probe Backing                1.1306e-004   7.2807e+007
Measurement Probe:Probe Backing_1        2.0863e-004   3.9455e+007
—————————————————————————-
**Sum**                                            1.0775e-001   7.6390e+004

And then Aluminum

Frequency/Hz  2.44270000e+009
Energy/J      2.60714955e-007

Layer     Solid       Conductivity   Mue           Loss/W(peak)  Q
—————————————————————————-
Copper (hard-drawn)   5.9600e+007    1.0000e+000   1.3125e-002   6.0973e+005
Resonator:Tuning Plate                   7.3542e-003   1.0882e+006
Measurement Probe:Probe                  3.4224e-003   2.3384e+006
Power Probe:Probe                        2.3446e-003   3.4134e+006
Resonator:Tuning Plug                    4.1946e-006   1.9079e+009
Aluminum              3.5600e+007    1.0000e+000   1.1812e-001   6.7750e+004
Resonator:Cavity                         1.1812e-001   6.7750e+004
PEC                   5.8000e+007    1.0000e+000   3.1734e-004   2.5219e+007
Power Probe:Probe Backing                1.1232e-004   7.1248e+007
Measurement Probe:Probe Backing_1        2.0501e-004   3.9036e+007
—————————————————————————-
**Sum**                                            1.3157e-001   6.0828e+004

Note that this is version 2.00 of the cavity, built only in CST 2010 which uses the new static data for hard-drawn copper.

I have also been thinking about how to power the cavity and Kevin helped me nail down a few variables.  For example, because the cavity has a really high Q, we might be able to use a signal generator to power the cavity, even if it only outputs mW.   The benefit of the signal generator is that it has very fine frequency control and we can match it perfectly to the resonant frequency., thereby not reflecting unmatched frequencies.   Once resonance steady state has been reached, then very little would be reflected as well

As I understand resonance, if we have a high Q, it means that just a bit of input power at the right frequency can set it to resonant, whereas a low Q, means we need a lot more power to start and keep resonance alive.  From another perspective, if Q is high that also means we can use a very small input over a long period of time and end up with a very strong resonance.

Unfortunately, it will take much too long, on the order of days.  Most signal generators output 1mW and if the cavity can hold 100W at steady state, then it would take 100,000 seconds or 27 hours to reach.   27 hours is doable, however, Shawyer said that his cavity contained 17 MW of energy (17 megawatts!!, emdrive.com) and it would simply take too long with only 1mW of input!

On a related note, there is something I don’t understand about Shawyer’s cavity – Shawyer said his cavity contains 17MW of energy, but at 1KW of power, it would take almost two thousand seconds (or ~ 30 minutes) to reach 17MW!!?  His test runs never last for more then a few minutes and movement occurs between 10 and fifteen seconds after startup.  Shawyer says that 15 second start-up delay isn’t pumping resonance either, but “The engine only starts to accelerate when the magnetron frequency locks to the resonant frequency of the thruster, following an initial warm up period.” – Hmm, thoughts anyone?

This status update turned out longer then anticipated because I wanted to be able to report something substantial and results seemed to be just one more simulation away.